Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 2012 HID Thread (Info Only No Arguing)
View Single Post
Old 11-10-2012, 10:52 AM   #300
Bwill9886
Focus Enthusiast
 
Bwill9886's Avatar
 
Join Date: Jan 2012
Fan#: 93444
Location: Collinsville, IL
What I Drive: 2013 Rallye Red Civic Si

Posts: 455
FF Reputation: 2 Bwill9886 Good Standing Member
Buy-Sell-Trade Rating: (6)
Quote:
Originally Posted by BaconZombie View Post
I just spent and hour and a half trying suggestions from Xenonsupply, but nothing worked. I may remove the actual plugs from the resistors where they plug into the stock light bulb harness, and run just straight connectors, since they don't seem to plug in very well. Other than that, I'm out of ideas. They suggested I try it without the relay harness, but the lights wouldn't stay on like they.
Seriously, I would try what I suggested. Mine were so off on being connected the resistors weren't even working. I have a suggestion on how to keep the connection plug-and-play in the video. It's towards the end.

Quote:
Originally Posted by zolemite View Post
I would say to anyone reading this far to just get the harness and resistors from OP's link. Everyone who ordered from them have had no problems. I bought my HID's from Ddmtuning though.
You can go with the relay from them, but their resistors are more expensive than what you can find on ebay and are no better.

Just throwing out my experience. An ebay link to alternate resistors has been posted a few times in the thread.

Quote:
Originally Posted by 2011Fiesta View Post
Where did people mount the ballast if they bought the kit from retrofitsource.com? I'm going to install mine soon and need ideas on where to mount

Sent from my HTC Rezound using FF Mobile
Check out my video a page or two back.

Have the same ballasts and I show where I mounted mine.
Bwill9886 is offline  
    Reply With Quote