Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - JRSC just installed....car will turn over but won't idle
View Single Post
Old 10-30-2012, 06:06 PM   #1
mj22
Focus Jr. Enthusiast
 
Join Date: Feb 2006
Fan#: 32067
Location: australia
What I Drive: 2003 silver 2.0. zetec

Posts: 30
FF Reputation: 1 mj22 Good Standing Member
Buy-Sell-Trade Rating: (0)
Unhappy JRSC just installed....car will turn over but won't idle

Hey Everyone,

I have just finished up installing a JRSC kit on my car.

I went to start the car for the first time this morning and have run into a problem.

When I start the car it turns over as usual with the indicated revs jumping to 1500 rpm or so and then they quickly drop down as used to be the case when starting the car. My problem is the revs continue to drop quickly until the car stalls. It is not as if the car is spluttering and the revs are slowly dropping until it stalls, they drop quickly.

I tried to correct the problem by applying some throttle when I start the car. This made no difference. While I could get the revs to climb a little higher at start up by applying about 10% throttle, no amount of throttle will stop the rpm dropping - if anything applying the throttle seems to make the car stall more quickly.

Can anyone offer their thoughts on what they think may be the problem?

I will do the usual checks for vacuum leaks once I am home tonight however given how quickly it is stalling this seems like it may not be the problem. Most people seem to just have a really rough idle with vac leaks. Could be a massive leak somewhere

Is it possible it could be the tune? I have an Xcal 3 and only have a base tune loaded on their which the tuning will be adjusting once the car is running. I've heard mention of custom tunes not supplying enough fuel for start?

Any help would be great!

Thanks

Mike


mj22 is offline  
    Reply With Quote