Focus Fanatics - View Single Post - Issues with new 2012 Ford Focus
View Single Post
Old 10-29-2012, 08:52 AM   #1720
armoore
Focus Jr. Enthusiast
 
Join Date: Oct 2012
Fan#: 104658
Location: Mukwonago, WI
What I Drive: 2012, Red SEL Hatchback

Posts: 26
FF Reputation: 1 armoore Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by ElGatto View Post
Perhaps we should hear from those who experienced leaky seals and if and when the problem was rectified or, better yet, how the problem was determined.
Well you can look up clutch replacement & transmission issues with the 2012.

http://www.focusfanatics.com/forum/showthread.php?t=299751

http://www.focusfanatics.com/forum/s...298984&page=36

My symptons were stalling in intersections, deacceleration on highways, shuttering when accelerating. Plus multiple other issues. The dealer finally listened about the TSB that stated that seals could be going bad, they lifted the transmission, transmission fluid had leaked in the clutch housing because of bad seals. Therefor the result of replacing the seals and clutch pack.

This had been stated to other dealers that I had taken the car to and just was told everything was up to date and there should be no issues. I told them about the seals but they were told by Ford that is how the car should run and I should give it's "breaking in period" I was already at 23000 miles - past the "breaking in period" Ford is having issues with their seals, not everyone but there are enough out there that they should be concerned about it. All they symptons I had a lot of people are having and being told that "it's normal" Also another sympton is that if the car is driving differently with the TC off - most likely clutches are the issue. With the clutches being wet the TC feels it needs to take over.
armoore is offline  
    Reply With Quote