Focus Fanatics - View Single Post - 2003 Ford focus hesitation + electrical glitches
View Single Post
Old 10-27-2012, 11:40 AM   #1
ddogg777
Focus Rookie
 
Join Date: Oct 2012
Fan#: 105357
Location: Albany, NY
What I Drive: 2003 Ford Fous LX

Posts: 2
FF Reputation: 1 ddogg777 Good Standing Member
Buy-Sell-Trade Rating: (0)
2003 Ford focus hesitation + electrical glitches

Hey everyone, I'm new to the forum since I have now switched to Ford vehicles since they denied bailout monies. I currently have my little Focus 2.0 LX with an evolving glitch. For a couple months, I noticed some subtle hesitation while cruising at low speeds. Then one day it got real bad, to the point it was difficult to come off the clutch. A CEL reported misfire in cylinder 2, with which I replaced the spark plugs and wires. That seemed to help with the stumbling but not the hesitation at cruise. Next, the dashboard gauges started acting funny: gauges resetting, swinging left-to-right, staying at 140mph, battery light would flash on after one of these cycles. I could also hear clicking under the dash which turned out to be the battery saver relay. I checked all of my fuses/relays and polished/greased my battery terminals (12.7v off, 14-17v running), yet the problem still persists. On a whim, I decided to disconnect the 3-wire plug to the alternator and viola...it ran perfectly and the gauges and saver relay stopped acting crazy, with the exception of the battery light which I expect at this point. So what is my problem? ECU, wire harness, or alternator?


ddogg777 is offline  
    Reply With Quote