Focus Fanatics - View Single Post - New here 2003 zx3 5 speed long intro :)
View Single Post
Old 10-25-2012, 05:03 AM   #22
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,065
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
For correcting flow on the MAF- it's flat, looks like a credit card sort of. There are 2 holes that the air flows through. One is near the connector, and one is on the opposite corner. The one nearest the connector is where the air flows out, and the one furthest away from the connector is where air flows in.

If that's not the problem then you need to post a thread in General Technical Chat. This particular thread should be in Duratec Performance. Moving it to Tech chat won't do you any good. People who answer threads in there don't usually answer new threads with 3 pages. Once we get a problem, we latch on to it until it's resolved, then move on.

If you want, you can mess with your buddy. Ask him how he thinks you're supposed to change the timing belt since the valve cover doesn't have a timing belt inspection cover.

Moved to Duratec Performance.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote