Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Fuse 32 keeps blowing
View Single Post
Old 10-22-2012, 02:12 PM   #1
Jamesnorge
Focus Rookie
 
Join Date: Oct 2012
Fan#: 105161
Location: Sandvoll, Norway
What I Drive: Focus MK1 Ghia 1999 Silver

Posts: 2
FF Reputation: 1 Jamesnorge Good Standing Member
Buy-Sell-Trade Rating: (0)
Fuse 32 keeps blowing

Hello
I'm hoping that one of you Foci experts will be able to help me with this problem.

Car affected is a British mk1 1999 Ghia.

I was out for a drive to get the groceries and when I was coming back home I noticed that the dash lights weren't on even that my headlights were.

I checked the fuses when I got home and found Fuse 32 had blown, the handbook says that this fuse is for the light switch.

Items affected by the light switch fuse blowing were, the instrument panel and heater lights, the tail lights, number plate lights and front parking lights. I think it also affects the wing mirror to some extent.

I changed the fuse and all came back to life for about two minutes when the fuse blew again.

I checked the wiring in the boot (trunk) and this looks like new from what I could see of it.

Checked the earth points in the engine bay, the one near the battery looked great but had to clean up the one opposite the steering pump.

Changed yet another fuse and all came back to life again for another few minutes.

A bit stumped at this stage.

Can you help???


Jamesnorge is offline  
    Reply With Quote