Focus Fanatics - View Single Post - stealthzx3's ZX3 build
View Single Post
Old 10-13-2012, 09:55 PM   #866
stealthzx3
Enthusiast
 
stealthzx3's Avatar
 
Join Date: Jan 2012
Fan#: 94260
Location: Pulaski, WI
What I Drive: 2003 Black ZX3 SVT, 2001 Black ZX3

Posts: 6,512
FF Reputation: 9 stealthzx3 Good Standing Member
Buy-Sell-Trade Rating: (22)
today was another crap day. i walked around at work for 4 hours with soaked feet.
anyways about the car;
i got my wires in the mail! they are blue taylor 8.2mm. and i got mastercraft (oem) plugs yesterday. so i replaced it all earlier today. it ran great! i wanted to try it out, so i drove to town. no issues. until...

i get out of walmart and see rainbows on the ground coming from my car. i was dumb and just figured it was more ps fluid. nope! i started it up, and man it reaked like gas tremendously. immediately i turn off the car and pop the hood.

FML. the same thing happened. the hose popped off the little plastic valve and pissed all over my bay AND my brand new plugs and wires!!! at this point i was irate. called a buddy and turns out when i replaced my fuel lines a while back i didn't do it properly. apparently you are supposed to heat up the hoses and push them on the valve. then they cool and shrink on. i had no idea.

soo went back inside walmart and got hose clamps. luckily they did the job to get me home. now i took everything apart again and it is all drying/evaporating in the garage.

__________________
Focus Revolution

2003 EAP SVT #2752
stealthzx3 is offline  
    Reply With Quote