Focus Fanatics - View Single Post - focus leans while driving
View Single Post
Old 10-07-2012, 10:10 AM   #24
Some Guy From NY
Focus Enthusiast
 
Some Guy From NY's Avatar
 
Join Date: Jul 2012
Fan#: 101517
Location: Brooklyn, NY
What I Drive: 2012 SGM Focus SEL sedan DCT

Posts: 493
FF Reputation: 3 Some Guy From NY Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Rogerschro View Post
Has the REAR suspension, bearings and brakes been checked? It's a long shot, but there may be issues with the rear affecting the handling and steering. That could cause pulling and ride height but feel like it is coming from the front. Do you use the parking brake? May be sticking, or stabilizer bar is loose, Bad bearings etc. One other thing is the motor mounts, that could cause lean through torque and pulling, also thunking noises, vibration and so forth.

No the rear has not been checked. I do not have a difference in ride height and I do not use the parking brake, nor do I have any thunking/clunking or vibration.

As a side note, I had my rear swaybar replaced with the Steeda bar, and I have had the rear motor mount replaced with the MS3 RMM.


This pull is definitely not normal. I have never driven a car that does this. Yes I know sometimes they tend to pull but definitely not as much and as often as this.
__________________
Mods: Drop in K&N filter, Steeda RSB, MS3 RMM, Remote start, Llumar tint, Ti engine cover, Husky floor mats, OEM splash guards
Some Guy From NY is offline  
    Reply With Quote