Focus Fanatics - View Single Post - Nothing but problems pt2
View Single Post
Old 10-05-2012, 03:47 PM   #78
jagreene
Focus Jr. Enthusiast
 
Join Date: Aug 2012
Fan#: 102678
Location: ardmore, PA
What I Drive: 2012, Kona Blue, Focus SE

Posts: 36
FF Reputation: 1 jagreene Good Standing Member
Buy-Sell-Trade Rating: (0)
An update for everyone. Unfortunately I do not have my car back. (I believe it's been a month now). The clutch was replaced twice but because the first one was faulty a horrible smell was burnt through out the car. To get rid of the smell a plasma ionizer was used (never heard of it before this) and now my car smells of a horrible chemical. What's funny is the dealer tried to tell me a few times it "didn't smell" anymore and when I drove to pick up my car and immediately picked up on the smell they agreed it does indeed smell. It's taken a week of back and forth between the dealer to agree to detail the car (the smell can literally make you feel ill) but I am not confident at this point that anything will ever be right with the car again. If the windows are down the car doesnt smell quite as bad but the second they are up for an hour or more the smell is back in full force. I am going to give the dealer one more time to fix the problem before I have them buy it back. It's a shame because I finally got the clutch problem addressed after months of arguing and I was given a whole new one. I have respiratory health issues so a chemical smell like this is absolutely intolerable for me.

The good news for anyone else getting their clutch replaced is this shouldn't happen to you. It only happened because the first clutch was "bad".
jagreene is offline