Focus Fanatics - View Single Post - 2001 Focus ZX3 - Replacing Fuel Pump & Driver Module
View Single Post
Old 10-05-2012, 01:11 AM   #5
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,430
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
Quote:
Originally Posted by NickStone View Post
Tried to bleed the system by turning the key on multiple times for 5 seconds at a time. I never heard any noise from the tank, that I sometimes did in other cars when the car was turned and the pump kicks on. But I can't really remember if I ever heard the pump kick on in this car...
Every time the key is cycled you should hear the fuel pump prime.
If you don't we're going to start there.


Quote:
Originally Posted by NickStone View Post
The only possible lead I have is that....when the key is turned forward, the Check Engine light is on. I know that light has never been on when the engine is running, but not sure if it lights up when the key is turned & engine not started yet. For diagnostic purposes, it doesnt seem like that light should light up even without the engine running if there's no problem.
The engine lamp is supposed to light up with every key cycle and illuminate for ~5 seconds (something like that). As long as it lights up and goes off when you start the car, it's working.



So lets try and get this no fuel pump priming thing fixed first.

The priming is controlled by the "Power Hold Relay". It's located in the underhood fuse box. When you turn the key to 'Run' power comes from the ignition switch to the PHR, from there it goes to the Fuel Pump Relay, on to the pump:




So we've got 2 relays to check (we know the fuses are good, don't know if power is actually there, but lets assume it is).



The relays are a bear to remove. Every time I try the plastic cover pulls off first.
If the cover pulls off the PHR, push the silver part with your finger (battery connected). You should hear the fuel pump prime. If it does that relay is good, as is the fuel pump relay. And if all that dies happen, it's not a fuel issue.

But lets just hope none of that happens and this is an easier fix.
No fuel pump prime, disconnect the battery and remove the relay. If you look at the part # on it you'll see there are a couple in the box with that same # on them, they are interchangable (still doesn't make them any more fun to remove). Swap a good one in and see what happens.
Hopefully the car runs again. Then it's simply a matter of replacing a relay.

Actually lets backtrack 1 step first. The grounds.

There are 2 to check.
The first is for the PHR. It's the Black/Orange wire on the negative battery terminal. But if this guy is bad you'll notice other things not working. All this stuff:



If any of that is working, the ground is good.

So on to the next, the ground for the FPDM (the real FPDM). It's a solid black wire coming from the module and grounds under the rear seat, flip it up and pull the carpet on the passenger side back. You'll see this box (left of the fuel pump):




The ground is the one on the L bracket. Remove it, clean it with some emery cloth and put it back, just to make sure, you're there so why not.

Turn the key and see what happens.
If nothing them move on to the above relays.


These 2 are what I'm thinking are the issue. There is one more thing that could be the issue with fuel pump power though, the actual ignition switch.
__________________
Don't "think outside the box".
There is no box.
Do it correct, or do it twice.
iminhell is online now  
    Reply With Quote