Ford Focus Forum, Ford Focus ST Forum - View Single Post - 2012 Ford Focus, Quality Job None!!!
View Single Post
Old 10-01-2012, 09:34 PM   #1
ki4csq
Focus Rookie
 
Join Date: May 2012
Fan#: 99155
Location: Deatsville, AL
What I Drive: 2012 Sterling Grey Focus

Posts: 4
FF Reputation: 1 ki4csq Good Standing Member
Buy-Sell-Trade Rating: (0)
Angry 2012 Ford Focus, Quality Job None!!!

In March of 2012, I made the biggest Mistake I have ever made purchasing a car and it was buying this 2012 Ford Focus HB SEL. From Day one, I have had nothing but problems with it and they keep showing up even more...

Here is my list...
March 1, 2012 Picked up my Ford Focus and drove home. The very next morning I get in it to drive to work and the Sync System is unresponsive. It won't do anything, the screen shows the four areas, but won't respond, nothing, no voice commands or anything. The about 20 mins into my drive, the radio comes on, FULL VOLUME!!! All the WAY UP LOUD... and it still won't respond, I could not change the channel, turn it off, turn it down or do anything. I had to pull over, turn off the car, and then open the door and the radio finally went off.
Get back in and started the car and the radio seemingly worked just fine.
Off to the dealership... they reprogrammed the system with a "OS"..

Now, with the New OS, the navigation no longer works... had to wait on a new SD card.

Began to notice the transmission slipping and would not hold any hills and rolled back all the time. Got a notice in the mail and took it in for that...

New programming in place, this thing now really shifts oddly, maybe I can get used to it. But now my Mileage dropped from an average of 36 mpg, down to 30 mpg.... HOLY COW what a drop... Tried two tanks of gas, and different grades, still very low MPG... Back to the dealer, oh, and the Sync system locks up all the time still, but at least I am not having to jump out of the car...

The dealer, reprograms the car but says they can find nothing wrong...
OK, fine I will live with it I guess..

Then the Cruise Control stops working... Periodicity it would not come on, no matter which button I pushed, how hard. It would just not come on at all. Back to the dealer, they can find nothing wrong with it... but they reprogrammed it anyway...

Great, picked it up, get down the road and all I have on my screen is the Blue Oval now, and my windows won't roll down and the cruise control still won't work... Back to the dealer the next morning...
They reprogram the car again.... pick it up, all seems to be well....

Well, I thought on the way home (which is 40 miles one way), I can't get the cruise control to come on... So I get mad and I punched the steering wheel... the Cruise Control came ON!!! Dealt with it this way for a couple of weeks, and started video recording each incident.

Month 5, Back to the dealer, fortunately on the way in the cruise control did not work. And the dealer verified the issue... Great, they kept the car 4 days and replaced the clock spring, steering column wiring harness, the media and cruise control buttons, a computer, and reprogrammed the thing again.

Is it working, seemed that way for a few weeks, then Every time I started the car I would get a Microsoft Updating Window... that went a way after about a week, but I started getting another notice when I put it in reverse (I have just the radar) that my Backup Camera has Malfunctioned... I don't have a backup camera... got that randomly.. Great.. another issue to add to the list at my next service, so I thought.

Then, the Cruise Control stopped working again... WTH...
I emailed the Ford Direct, and called the dealer.. I chatted with Ford, they escalated the issue and I took the car back to the dealer... They could not verify any of those issues but at the direction of Ford put in a brand new program on the system... that was last week..

OK, fine, on the way home, the Cruise Control would not come on at all.. SIGH... My wife used the car the next day and the same thing the cruise control would not come on. Then we drive it to Florida for the weekend, NO CRUISE CONTROL FOR 200 MILES..... THAT SUCKS!!!!

Then yesterday my daughter drove it home from Florida, no cruise control...
I got home today get in the car and notice a bad musty smell, I have noticed this before but we have had little rain this summer and the car is garage kept, I chalked it up to sweaty gym short and shoes I keep in the car. But Yesterday my daughter drove in the rain for 4 hours through substantial down pours. Parked it in the garage overnight, and today I look in the passenger side floorboard and there is 2 inches of water in the car... Yes, not just a little water or dampness but 2 Inches of Standing Water INSIDE the car... the carpet and floor mat is soaked.... WTH...

This car is obviously a lemon, and I am taking it back to the dealer in the morning and demanding a replacement. I also have a call into the CSM that I have been dealing with for the last couple of weeks on the cruise control issue. But this is the last straw with this car...

I have a Focus with serious computer/electrical issues and now a substantial leak when it rains.... I hope nobody has had this many issues with their Focus, but it seems that Quality was Job None on this one....
If Ford does not do something serious about this, I will post here and everywhere I can... If they don't take care of this, this will be the LAST Ford I ever own. They will loose a 20+ year Ford Exclusive Customer... What is sad is that this car has been in the shop more times in the last 8 months, than ALL my Fords over the past 20 years combined....


ki4csq is offline  
    Reply With Quote