Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Problems with 2006 GHIA TDCI
View Single Post
Old 09-17-2012, 09:51 AM   #3
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,272
Points 27,546, Level 98
Points: 27,546, Level: 98 Points: 27,546, Level: 98 Points: 27,546, Level: 98
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 13%
Activity: 13% Activity: 13% Activity: 13%
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
It could be a leaking injector. Are you actually losing oil, or just assuming it's oil? How fast are you losing oil?

Also, I see where someone used vinyl electrical tape to rig up the oil breather- I'd definitely fix that with the proper part, then clean the area as best as I could with rags. If the engine will idle sufficiently, you can pressure wash an engine, but I always do it with it running so that if it cuts off while you're washing- you know where to look. Anyway, get it cleaned up, then you can more easily find if there is another leak. Usually really bad auto problems stem from more than one problem, so fix the obvious stuff first.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote