Ford Focus Forum, Ford Focus ST Forum - View Single Post - Modified 2005 ST P0420
View Single Post
Old 09-07-2012, 05:31 PM   #1
afraziaaaa
Focus Addict
 
afraziaaaa's Avatar
 
Join Date: May 2007
Fan#: 47383
Location: Green Brook, NJ
What I Drive: 2005 ZX4 ST

Posts: 1,156
FF Reputation: 24 afraziaaaa Great Standing Member
Buy-Sell-Trade Rating: (10)
Modified 2005 ST P0420

Ok, so I fixed the last code that I had (P2004) with new vacuum lines.

Now, I am trying to get a NJ inspection (never move to NJ if you have a modified car unless its more than 25 years old).

I had to detune the car to the stock tune because none of the electronic monitoring systems would show up as "READY" for the inspectors while it was running on aftermarket tune. So now, it runs, but I have CAI, 2.5" exhaust and Crane stage 1 cams so I am most likely incredibly lean. Once all the systems reset, the code P0420 came up. It basically means that the cat isn't working properly.

So, my plan is to go back to stock cams and see if the code goes away.

Two questions:

1. Has anyone experienced this or a similar scenario?
2. If the code does not go away once I replace the cams, is it still possible that I have a bad downstream O2 sensor?

I have already looked all over the internet for information and found what I needed. I am not looking for info, but more for anyone's personal experiences and tips/tricks to get this fixed without having to drop several hundred dollars for a new exhaust manifold.

Once I get the car fixed and inspected it is going up for sale, along with several of the bitchin aftermarket parts I have for it. I needs me a truck!

Thanks for looking and for any advice.


afraziaaaa is offline  
    Reply With Quote