Focus Fanatics - View Single Post - 2012 Titanium Front Strut Low Speed Noise (Clunk/Rattle)
View Single Post
Old 08-31-2012, 09:30 AM   #1102
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,096
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by revhigh View Post
Just go t mine back today. Replaced both side springs, bearings, and nuts and bolts.

Seems to be fixed for now...

...Overall very pleased with the work .... and my dealership, who has always been upstanding and ultra-fair as far as I'm concerned...
This is great news! Please keep us all updated and go here to share your story: http://social.ford.com/.

Quote:
Originally Posted by jrn146 View Post
...Just curious Thomas, does your Focus clunk?? I really don't see where involving a CSM is going to help anything. If the dealership did the TSB and the noise is still there what else can they do, change the same parts again?
It did clunk; my dealer performed the TSB and it's doing well. Think of a CSM escalation as a record. He/she can coordinate with you and the dealer on any future repairs and alert other reps to the issue.

Quote:
Originally Posted by Mistofoleez View Post
...I'm the "trouble-maker" who started this whole thing. I'm shocked! 92 pages long!?!...Not only are my tires now "cupped", they can't seem to make it stop making noise. Like most of you, I am very tired of taking it in for this issue. Has ANYONE seen resolution?
Quote:
Originally Posted by killjoy View Post
OK they just delivered my focus back and the service order says they replaced the "left front sway bar link". If the sound is still there I will post again.
Quote:
Originally Posted by killjoy View Post
It is still clunking
Hey, you're not a trouble-maker, Mistofoleez! Have you guys talked to your regional Customer Service Managers about this? If not, please PM me your VIN, mileage, phone number, and dealer info; I'll send this in for further review.

Quote:
Originally Posted by Timthom62 View Post
I checked my sister's 4/20/12 build SEL yesterday evening. No mass dampers installed and no reports of clunks or rattles.
Quote:
Originally Posted by zx3matt View Post
My SEL has that damper. Factory 17" wheel car.
I'll bring this up with the appropriate contact.

Quote:
Originally Posted by eriksarnstrom View Post
Still waiting for 9/15 parts.... :(
Is this the date your dealer gave you? If you'd like this to be sent to your Customer Service Manager, please PM me your VIN, mileage, phone number, and dealer name.

For all, if you're still experiencing front-end clunks after the TSB has been done, please PM me your VIN and I'll document it appropriately.

Have a great Labor Day weekend,

Thomas
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordService is offline  
    Reply With Quote