Ford Focus Forum, Ford Focus ST Forum - View Single Post - 2003 ZTS - horrible gas mileage - 16.3mpg - HELP
View Single Post
Old 08-28-2012, 03:50 PM   #10
DrkKnight614
GO Green
 
DrkKnight614's Avatar
 
Join Date: Oct 2004
Fan#: 14522
Location: Long Island, NY, United States
What I Drive: 2003 2.0L Grabber Green Zx3

Posts: 11,143
FF Reputation: 47 DrkKnight614 Great Standing Member
Buy-Sell-Trade Rating: (0)
Posted via FF Mobile Hmm, in the beginning years of my car thats pretty much what I was getting, no matter what I did. Let my car break in, nothing changed, blah blah blah. Finally after I Seafoamed the thing with some friends, mileage went up. I'm sure you've unhooked the battery and reset the ecu sometime during all those replacement parts...if not do it. Tranny flush may gery well fix the issue, if its not working properly it'll suck up your mileage greatly for sure. Id say clean the IAC if you are having idle issue, if you think you are having trans issues or it has a lot of miles do that next, if not do seafoam. If that doesnt work do trans work. If NOTHING WORKS, go back and check everything. Such as, did you clean your MAF before or after the K&N, excessive oil from a new filter can guck up the sensor. Did you use any fuel cleaner after u put in the fuel filter. Well diesnt matter because if you seafoam you'll want to replace your fuel filter anyway. Whatever the seafoam frees up will get clogged in it, but go thru your entire gas in the tank first. Good luck
DrkKnight614 is offline  
    Reply With Quote