Ford Focus Forum, Ford Focus ST Forum - View Single Post - NO indicator for winshield wiper fluid
View Single Post
Old 08-25-2012, 01:11 PM   #69
BetaDnB
Drum n Bass Lover
 
BetaDnB's Avatar
 
Join Date: Jul 2011
Fan#: 87466
Location: Buffalo, NY
What I Drive: 2012 Silver SE Sport

Posts: 1,985
Points 2,209, Level 28
Points: 2,209, Level: 28 Points: 2,209, Level: 28 Points: 2,209, Level: 28
Level Up 40% Completed
Level up: 40% Level up: 40% Level up: 40%
Forum Activity 8%
Activity: 8% Activity: 8% Activity: 8%
FF Reputation: 11 BetaDnB Great Standing Member
Buy-Sell-Trade Rating: (0)
Sorry I haven't replied. I was waiting until after my service appointment today. I just got home with her. With all due respect, Thomas, the manual still doesn't specify any trim levels that I could find. I've also been told by somebody here with access to a service manual that the service manual doesn't even list specific trims. This leads us all to believe it should be on all trim levels.

Anywho, I had a very pleasant experience with the dealership I went to today. West Herr Ford in Amherst. I let them know I was requesting this TSB along with TSB 12-5-5 for the manual transmission. They gave me no hassle and simply asked me my symptoms. My paperwork states that both TSBs were verified and performed, along with the wiper motor seal recall. I can't comment as to the effectiveness of either of these TSBs yet because A) I'm not wasting a full tank of fluid to see if the indicator appears (although I should so we can have a final answer on the SE Sport) and B) because I've been driving around in an 04 Neon 5 speed all day and let me tell you, they are two completely different machines, especially when it comes to the clutch engagement point.

Steve Baldo Ford in Niagara Falls will no longer be used by me. I've had nothing but problems with them since the first time I went there including a nice dollop of grease on a door (that didn't come from them (according to the service advisor (even though there was nowhere else I could've possibly picked it up and it was noticed as soon as I left))), to an improperly installed fog bulb (which I can easily handle on my own now that I know the easy way to get to it), to giving me a complete hassle of having these TSBs done without having to go in during the week. They told me it's a transmission issue without even looking up the TSB.

The only downside of having these TSBs done today was both of my trip computers were reset. I had been using Trip B to determine my overall MPG. I was sitting at 33.1 over just about 15,000 miles.
__________________
Sedan Revolution #249 - 2012 SE Sport - ╠╬╝ - Ingot Silver - 201A - K&N w/ snorkel delete - Blox Type R Knob
BetaDnB is online now  
    Reply With Quote