Focus Fanatics - View Single Post - HID Headlight issues. Ideas?
View Single Post
Old 08-21-2012, 01:22 PM   #1
CSOleson
Focus Rookie
 
Join Date: Aug 2012
Fan#: 102882
Location: Pella, IA
What I Drive: 2000 Silver zx3

Posts: 6
FF Reputation: 1 CSOleson Good Standing Member
Buy-Sell-Trade Rating: (0)
HID Headlight issues. Ideas?

A few weeks ago I was pulled over for having a headlight out, on my way to walmart. So I bought what I thought was the proper headlights, when and took everything out to replace them at 1 am, only to find that they are aftermarket headlights. So I ordered the HID D2S for my hella HID kit that is in the car (put in the vehicle by the previous owner).

I got the headlights (a pair to replace them both at the same time) and first replaced the left side, the side that was out. I put in the new HID light and it worked right away, making sure not to touch it with my hands. I turned the car off, went on to the other side, replaced this light, turned the car on, and nothing. Both sides were now out. Confused, I tried putting the old one back in. Nothing. After trying over and over to see if I screwed something up, I tested the fuses a few days later. All of them were good. If I turn on the lights (even though they don't actually turn on), the right turn signal does not work, but with the lights left off, the turn signal blinks quickly but still works.

If it isn't the fuses in the fuse box, is there an inline fuse? What else could cause this? I've bought a wire tester but I have never used one. How do I use the wire tester to test if the wires are in fact working? I would greatly appreciate any feedback that I can get. I cannot afford to take my card to Ford, as I am a broke college student (not even joking). Please let me know!


CSOleson is offline