Focus Fanatics - View Single Post - 2012 Ford Focus: 1 year, 6,000 miles, 6,000 electrical problems later :)
View Single Post
Old 08-05-2012, 03:38 PM   #13
rvretirement
Focus Rookie
 
Join Date: Aug 2012
Fan#: 102222
Location: Pensacola, FL
What I Drive: 2012, White, Hatchback

Posts: 2
FF Reputation: 1 rvretirement Good Standing Member
Buy-Sell-Trade Rating: (0)
Love my Focus, But.....

I have a 2012 Focus and this is my third Focus. I love the gas mileage and the convenience and ease of driving. I live in my RV and travel all over the US so any problems and I usually end up going to a dealer that is new to me.

I bought it in March and in June it began having problems. While driving the radio and A/C would just turn on. I'd get an error message in the little window that said "Hill Start Assist Not Available"-while driving down the highway. At times it wouldn't start but after waiting awhile it would. Sometimes I can't unlock/lock the doors/hatchback and sometimes the alarm goes off and the only way to silence it is by putting the key in the ignition. When I turn the car off it resets the odometer, fuel efficiency readout, time traveled, and distance to empty. One time after filling it up it took at least 10 minutes for the fuel gauge to register.

The first dealer (Washington) I took it to, after talking with Ford, said they didn't know what was wrong and took all the computer connections apart and put them back together hoping that would solve it. They actually had it twice. Next dealer (Idaho)-I had to have it towed there as it just would not start-decided the battery was dead and replaced it with a new battery. I'm next traveling to California so hopefully it won't happen again but if it does it will be yet another dealer. I've already spent about $200 in fuel and motels to deal with this. I am alone and over 70 so having a car that I can't count on is very stressful. I've had 8 Ford products and loved them all but I just don't know what to do now.
rvretirement is offline  
    Reply With Quote