Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - SPI Rebuild
Thread: SPI Rebuild
View Single Post
Old 07-23-2012, 09:44 PM   #3
Condor945
Focus Rookie
 
Join Date: Jun 2012
Fan#: 100774
Location: Big Lake, MN
What I Drive: 2001 Focus SE 2.0 SOHC

Posts: 7
FF Reputation: 1 Condor945 Good Standing Member
Buy-Sell-Trade Rating: (0)
Well just to clarify on what I'm experiencing... Overall the car runs and performs very well. There are no weird knocks or noises. Drives great and just like it did before the rebuild. What is occurring seems to be a little random. It has not done this to me while driving, but only when it's idling in my garage. The car has a high and low idle. High idle is fine (like on a cold start) but when it warms up and idles down it had a hesitation. Not a misfire, but like a lack of fuel, spark, or air and just has a little shutter. I can hit the gas and it'll go away, but comes right back when it idles back down. Twice now when it's just been idling in my garage it has died after one of these shutters. Just bogs down low, dies, but I can fire it right back up. Then after restart it'll still idle a little rough, but not die even after letting it idle for 10-15 minutes.

With the rebuild the spark plugs, wires, and ignition coil pack were all replaced. I never had an issues that were fuel related before the rebuild so I don't think it would be that. Could a vacuum leak cause this? Or the fact that the battery was out for two weeks cause the PCM to reset in which it just needs time to relearn the car? Any suggestions?
Condor945 is offline  
    Reply With Quote