Focus Fanatics - View Single Post - 2012 Titanium Front Strut Low Speed Noise (Clunk/Rattle)
View Single Post
Old 06-26-2012, 07:45 AM   #583
TiPilot
Focus Addict
 
TiPilot's Avatar
 
Join Date: Jan 2012
Fan#: 93667
Location: Dayton, OH
What I Drive: 2012 Ingot Silver Ti Hatch

Posts: 647
FF Reputation: 1 TiPilot Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by hand-filer View Post
Same situation here. Only I'm looking for a new dealer to work with. It took me 3 hours to clean up the aftermath caused by the present dealer.
I got the car back with mud on the carpet, mud on the door panel, grease on the passenger floor mat and grease on the headliner.
They offered to clean it. I told them they had done enough damage for one day thank you. On top of that the tech couldn't replicate the problem.
One lap around the parking lot with the shop foreman and we both heard the noise.
I like the car but hate the issues and the after service.
Ugh, I hear you. I've started going to a new dealer myself - and so far I'm quite happy with the new guys. The last dealer left grease/dirt all over my headliner and sunroof sunshade after replacing the sunroof glass seal. Grargh!
__________________
2012 Focus Ti Hatch | Ingot Silver | 401A, Nav, Winter Pkg, Moon Roof, Parking Tech. Pkg

Build Date: 12/2/2011 | New APIM: 4/4/2012
MFT: Factory v2.11, 3/14/12 Web -> v3.0.2, 9/24/12 Web -> v3.2.2, 1/24/13 Web -> v3.5.1, 8/13/13 Web -> v3.6
TiPilot is offline  
    Reply With Quote