Focus Fanatics - View Single Post - Suspension fix - no more front end clunk
View Single Post
Old 06-24-2012, 09:20 PM   #22
slowmazda3
Focus Enthusiast
 
Join Date: Aug 2008
Fan#: 58220
Location: Lake Forest IL, United States
What I Drive: a rental

Posts: 47
FF Reputation: 0 slowmazda3 Newbie
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by BigDandthegirls View Post
Wow! Thats a little rich for my blood. Guess you have to pay to play.
I agree. In the long run... there really isn't that much difference in cost between this replacement and 4 leaking front struts from Ford. There's a reason why they are so cheap.

Quote:
Originally Posted by Zillon View Post
Any particular reason you didn't go with Koni rears for a Mazdaspeed 3? They will fit.

I've been considering this option for some time now, good to see everything bolts up with minimal modification. Did you cut a hole in the cowl for adjusting the front struts, or do you plan to just set them and forget them?
I am running a 32mm rear bar in addition to stiffer rear springs that are progressive in nature. I wanted more compression damping than the Koni had do offer, and more consistency in damping force throughout the damper range of motion. There is alot of spring equivalent back there with the focus motion ratio and it needs a damper with a lot of compression and rebound force. (B8 >>> Koni in that respect).

No holes were cut. I set the rebound damping to "half" (1.25 out of 2.5 turns) and may bring that down to 1 turn depending on testing and the current alignment. I believe the chassis is still erring on the side of understeer, but without much more spring rate, I dont know how I could possibly reduce this. Keep in mind, this is at the extreme limit when the car is going in WAY hot.

Quote:
Originally Posted by Dysan911 View Post
Thats awesome that you were able to resolve this issue on your own. Big time kudos for taking this issue head on!. You've done a big service to this community as far as im concerned.

I know you wanted to go aftermarket on the struts, etc. Just curious if you felt the clunk was mainly due to the strut bearings and that someone could fix thiers by changing just that part or was there failure on all the parts you replaced as well?

Thanks!
Thank you. Part of the clunk was strut bearings, part was the broken strut. It was clear that the strut would clunk at the end of its stroke.

Quote:
Originally Posted by dyn085 View Post
I firmly believe that the clunk in my suspension is related to the top-cap/bearing assembly. Everything else in my front suspension was pristine, short of the gouging that occurred when the techs replaced my left strut.

I'm not horribly worried about it as I listen to my music rather loud (wrong answer, I know), but when I order the parts and make the swap I will be sure to drop intel here and in the clunk thread.
See above. Both the strut and the bearing caused the problem IMO.
__________________
I bought a mazda and all I got was some crappy motor mounts and wheelspin.
slowmazda3 is offline  
    Reply With Quote