Ford Focus Forum, Ford Focus ST Forum - View Single Post - Very frustrated!
View Single Post
Old 06-01-2012, 04:28 PM   #9
Mother Focus
Focus Addict
 
Mother Focus's Avatar
 
Join Date: Mar 2010
Fan#: 73292
Location: San Juan, PR
What I Drive: 2001 Money Pit

Posts: 1,428
FF Reputation: 13 Mother Focus Great Standing Member
Buy-Sell-Trade Rating: (9)
Quote:
Originally Posted by 1turbofocus View Post
Do a search and see if a local member has a xcal so you can do me a datalog , Sounds like a fuel issue

Tom
By fuel issue you meant fuel filter? Since it is under 2,000 rpm's...

Quote:
Originally Posted by cma8302000 View Post
A local mechanic who I've been going to for years changed all that stuff for me...AND he changed the timing belt for me...but I don't remember having this problem right after he changed it a few years back..this has been going on now for the past year...anyway, I will get second opinions from now on....I do remember someone saying it could be timing but then I also heard if it was the timing it would run bad all the time...UGH!! I AM SO CONFUSED! especially cause I really don't know much about cars....I will print out your response and see if my brother can check it out for me...first though, I will try the easy approach and clean the IAC if I can find it...I have to try and find a picture of where it is... <sigh>....thanks
IAC is on the bottom of the intake manifold although I don't think that's the culprit.
__________________
PTE 6262CEA
Pump Gas 385whp 319wtq
Race Gas 551whp 439wtq
Tuned by Fernando@RacingPartsSolution.com
Mother Focus is offline  
    Reply With Quote