Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Very frustrated!
View Single Post
Old 06-01-2012, 04:58 PM   #5
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,715
Points 18,426, Level 86
Points: 18,426, Level: 86 Points: 18,426, Level: 86 Points: 18,426, Level: 86
Level Up 16% Completed
Level up: 16% Level up: 16% Level up: 16%
Forum Activity 7%
Activity: 7% Activity: 7% Activity: 7%
FF Reputation: 49 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
What brand sparkplugs?
Motorcraft are recommended and tend to be the best option.

I wouldn't think anything you've replaced would have any bearing on the problem. Not sure who told you to replace all those things but, I would have more caution listening to them.

Has the A/C been serviced?
If not, it might have some bearing of the 'sputter'. Low system pressure can cause the compressor to cycle more often. Possibly often enough that the IAC can't compensate fast enough.


Backfiring and such sorta sounds like you may have a vacuum leak or the cam timing may be off. Has the timing belt been done?
It's possible whoever did the work didn't get it quite correct. This is something you can check yourself rather easily. Simply bring #1 to Top Dead Center, remove the valve cover and see if the slots in the drivers side of the camshafts line up. If they don't, cam timing is off and will need to be fixed.

Also, one of the sponsors has a scan tool loaner program that you might want to look into. 1turbofocus is his screen name and there is a thread floating around about his program, Xcal loaner program in the search box should turn it up. It's free professional help and well worth your time.
__________________
Don't "think outside the box".
There is no box.
Do it correct, or do it twice.
iminhell is online now  
    Reply With Quote