Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - My Ford Touch Thread
View Single Post
Old 05-31-2012, 02:03 PM   #1761
copernicium112
Focus Fanatic
 
Join Date: Jul 2011
Fan#: 87742
Location: Rochester, NY
What I Drive: 2012 Sonic Blue Ti Sedan

Posts: 1,868
Points 1,491, Level 21
Points: 1,491, Level: 21 Points: 1,491, Level: 21 Points: 1,491, Level: 21
Level Up 91% Completed
Level up: 91% Level up: 91% Level up: 91%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 4 copernicium112 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by WizeGuyDezignz View Post
With that being said, I've seen people say that they are going to trade or sell the car because of these issues.

With that being said, I completely agree that MFT should work as advertised and it shouldn't have this many issues. On the flip side, I think it's rash to want to dump the car because of it. It's obviously a software issue and Ford has already released an "update" once. Who says they won't do it again and possibly clear all of the issues up? If I'm not mistaken, didn't the Ford tech person from this forum say that they are indeed working on an update?

Fortunately I haven't had a fraction of the issues with MFT that some people are reporting here. But I also understand that the issues are real.
I wouldn't say I want to dump it over this, too much to like in other areas. Handles like a dream, IA keyless entry, and various other positives. Ford has actually released other updates though. You have one advantage in that what you have is what you know. For some of us, we consider this a step back appearance-wise, which is of course a matter of opinion, and a step back functionality-wise, which is a matter of fact. Another advantage you have is that your version was installed cleanly and shipped on your car from the plant.

When I first joined this forum I was awaiting my Focus. During that time several current owners received the update from version 2.10 to 2.11. Mine was in the time frame where 2.11 was what was installed at the plant. Mine was far less problematic than others on here were seeing, but again, it was a clean install at the plant. Some people installed 2.11 over 2.10 and it was fine but some people had a world of problems after 2.11 was installed over 2.10. Same seems to apply to the new version installed over 2.11. A lot of people are reporting it is fine and as you can see from this thread, several of us are having problems. I happened to land in that unfortunate minority this time. At first I was not happy with the look and loss of functionality in regard to the system but as time went on, I quickly realized that I wouldn't even care about that anymore if I could just get it back up to the level it was functioning at before the update.

I am working with the dealership and they have tried some things which didn't work. It is there now for an interface module replacement. If this doesn't work I don't what the next step is.

As you didn't have 2.11 you don't really know and believe me, I am not saying it was problem-free. It had its quirks/crashes/etc. but hell, at least it looked prettier when it was crashing compared to how this one looks when it is crashing :)

Ford also, quite frankly, put a lot of marketing muscle behind this and talked about how it was a faster, more reliable, better, more stable system so they kind of set themselves up for a lot of the vitriol thrown in their direction. They talked about how they were actually using beta-testers and placing it real-world employee cars for feedback and fixes before releasing it. Look through the thread, even people that had better luck with their update than me are seeing the same things - randomly changing audio sources, information disappearing, radio station frequencies not showing up in the buttons, overlapping text, and so on and so on. Not quite sure what these beta-testers were doing.

So, rant over and again, no, I'd rather not ditch a car with so many other positives over this but if they (Ford) can't get me back having it work at least as well as it did before, I don't know....
copernicium112 is offline  
    Reply With Quote