Focus Fanatics - View Single Post - New SVT...completley screwed (edit: not completely screwed anymore)
View Single Post
Old 04-20-2012, 08:32 PM   #78
focus_family
Focus Enthusiast
 
focus_family's Avatar
 
Join Date: Jan 2010
Fan#: 72232
Location: Hagerstown, md, MD
What I Drive: 00 White SE 02 CD Silver SVT

Posts: 351
FF Reputation: 2 focus_family Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by p0sitivevibez View Post
UPDATE-

it was the coil pack!!!!! Car is running and fast. He was concerned about idle (500rpms). Rear subframe is bent to hell to. Oh and previous owner actually pulled out the CEL lights and another light from the dash?
Lol I remember that..Josh did the dash test didn't he? And was like uhh..your cel doesn't work at all..haha freaking idiot..

Quote:
Originally Posted by p0sitivevibez View Post
Drove it to work today. Drives awesome. Sweet jeebus this thing is a rocket compared to my ZX3. Will have to replace front struts, front wheel bearings, front swaybar links, unbend/replace rear subframe. Now have a small crack in windshield, either gonna have it done or get the kit. Gotta get it inspected, tomorrows the deadline.

Sorry to FF community for my poor communication skills on this.
At least it is coming together and drive-able! I never found out..How bad was your car out of time? We're still thinking ours is like a tooth out of time. Sucks there isn't really any trust worthy shops around here to take it to and find out though..
__________________
Sedan Revolution #214
White 2000 Focus SE
CD Silver 2002 SVT Focus #1255
focus_family is offline  
    Reply With Quote