Ford Focus Forum, Ford Focus ST Forum - View Single Post - just bought SPI powered 2001 LX
View Single Post
Old 03-28-2012, 02:06 PM   #17
Chris_HT
Focus Addict
 
Chris_HT's Avatar
 
Join Date: May 2011
Fan#: 86229
Location: Houston, TX
What I Drive: Blue SVT 2002

Posts: 1,429
Points 1,526, Level 22
Points: 1,526, Level: 22 Points: 1,526, Level: 22 Points: 1,526, Level: 22
Level Up 26% Completed
Level up: 26% Level up: 26% Level up: 26%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 4 Chris_HT Good Standing Member
Buy-Sell-Trade Rating: (2)
from the original problems with car:

vibrations -> all 3 motor mounts completely useless, after changing em the difference was like night to day, anyway those were the aftermarket ones and the tbone failed again 3 months later, luckily it's cheap and i was able to change it so it cost me 25$.

jumbo jet sound -> well that was something around exhaust manifold that ruptured, with my car knowledge at the time i didn't even understand what the mechanic has explained to me :P


I had problem lately with wiring to the battery, solved in this thread:
http://www.focusfanatics.com/forum/showthread.php?t=283099


Currently I'm looking at belt and belt tensioner, and it's because of two things
1. i get the typical 'old belt' noise when turning on/off the AC
2. there is some vibration in motor that seems to be related to AC speed
__________________
Blue SVT 2002

Our Lady of blessed acceleration

Quote:
Originally Posted by Black&Tan View Post
But.... why read facts and investigate a claim when it supports your ideology?
...that should be written as 'The First Law of Internet Forums'
Chris_HT is offline  
    Reply With Quote