Ford Focus Forum, Ford Focus ST Forum - View Single Post - New SVT...completley screwed (edit: not completely screwed anymore)
View Single Post
Old 03-06-2012, 03:59 PM   #65
p0sitivevibez
Focus Fanatic
 
p0sitivevibez's Avatar
 
Join Date: Aug 2004
Fan#: 11223
Location: Taneytown, MD
What I Drive: SVTF

Posts: 1,567
FF Reputation: 1 p0sitivevibez Good Standing Member
Buy-Sell-Trade Rating: (6)
Ah the gas station where I tried to pump my own gas is where you must've saw me!!

Yeah I had them put the real tire back on and inflate it and had oil changed in Clifton I think? It went flat again around Philly.

Huge ups to Focus_Family, who thanks to them my car is running better than ever! Tranny mount was changed, spark plugs, ebay pos intake gone, and some other goodies. No more hanging or weird behavior. Little misfire, gonna do fresh OEM front o2 sensor, cheater for rear (either electronic one or spark plug fouler), Countour thermostat housing from Steve@Tousley and water pump, althought current water pump might still have some legs. The original mechanic said the flex was broken but it's too damn low to get a good look at it now. Will have to jack it up and see for myself. Hopefully that cures the misfire. Also new fan resistor is coming in and will flush the tranny fluid and radiator out this weekend as well. Agin HUGE thanks to the Focus_family (and they love theirs!) because Moesha would be SOL without them! Also got Moog swaybar link coming in, as one of mine is missing.

The seller didn't know anything about anything with the car, and I couldn't understand him well since he's from Poland. I wanted this car soo bad it clouded my judgement, but she's mine now and come hell or high water, she will be driveable.
p0sitivevibez is offline  
    Reply With Quote