Focus Fanatics - View Single Post - 588whp 500tq just got off the dyno :)
View Single Post
Old 01-16-2012, 04:12 PM   #154
Roushturboedzx3
I Fab Too Much
 
Roushturboedzx3's Avatar
 
Join Date: Jan 2007
Fan#: 42814
Location: CLearwater, FL
What I Drive: 2002 Liquid Gray ZX3

Posts: 4,733
FF Reputation: 20 Roushturboedzx3 Great Standing Member
Buy-Sell-Trade Rating: (18)
Quote:
Originally Posted by teamDFL View Post
I wouldn't be so quick to blame Ford on that one. See how the split begins where the bead on the nipple rests? That is the point of maximum stretch for the hose. When it splits around that line you have a poor quality hose. When you have a split perpendicular to that line you have a failure induced by strain. My guess is that someone has pulled on that hose, perhaps to get it off, or the engine was moved and the hose not disconnected.

Now, it could be a failure, but IIRC, that type of rupture is often associated with strain.
Your right it could be anything, but it always happens to the prebent hoses, the rubber gets thin when they bend it.

Quote:
Originally Posted by Joshuasvt View Post
Wow. Did they at least stop? Every time I've been hit I was parked on the side of the highway. It like throwing up a big neon sign saying here I am hit me! Well glad you guys are ok and the damage isn't too bad.
Naw they took off, my buddy chased them down and got a tag number luckily.

Quote:
Originally Posted by 1turbofocus View Post
Could he of hit it in a worse spot ?

Tom
Right wtf, im just glad he didnt hit it head on, the speed limit on the road is 60mph, so if he would of hit at that speed i think it would have been totalled.
__________________
New: 2012 Mustang GT premium
SOLD:RACE GAS 602whp 501tq Pump Gas SAE 454whp
Garrett GT3582r, Topmount, built motor, Ported head,Tuned by Fernando@RacingPartsSolution
I may not be the baddest, but the baddest dont Fu** with me
Roushturboedzx3 is offline  
    Reply With Quote