Ford Focus Forum, Ford Focus ST Forum - View Single Post - Battery Corrosion 2010 SE
View Single Post
Old 12-21-2011, 10:56 AM   #4
rambleon84
So mote be it
 
rambleon84's Avatar
 
Join Date: Nov 2007
Fan#: 51521
Location: columbus, OH
What I Drive: 2007 Dark Toreador Red ZX3

Posts: 5,487
Points 7,522, Level 57
Points: 7,522, Level: 57 Points: 7,522, Level: 57 Points: 7,522, Level: 57
Level Up 86% Completed
Level up: 86% Level up: 86% Level up: 86%
Forum Activity 23%
Activity: 23% Activity: 23% Activity: 23%
FF Reputation: 23 rambleon84 Great Standing Member
Buy-Sell-Trade Rating: (15)
Quote:
Originally Posted by BillyKeith View Post
2010 Ford Focus SE sedan, 4 cylinder. Seeing white corrosion around battery "hold down" but none on either terminal. Could battery be bad or beginning to fail?
not sure about your battery location/hold down but the same thing was happening with mine. I'm going to assume its the same thing I'm talking about.

I painted the bare metal hold down with some high temp black paint i had laying around. I took it off, cleaned off the corrosion and then painted it with a couple coats. Let it dry and then reinstalled it. I bet some of the liquid plasti-dip would work well for this hook too, just dip it and let it dry.

Mine was corroding right at the hook where it was anchored to the plastic (right above where the FSWerks sticker is on my CAI on this picture.)


I'm not sure why it was corroding there as it actually isnt touch the battery, so not sure if it was just the metal the hold down was made out of? I hit up the nut that screws the hook/hold down too but the paint wore off as soon as i reattached it
I havent noticed it corroding again yet, i painted it this past spring.
rambleon84 is online now  
    Reply With Quote