Ford Focus Forum, Ford Focus ST Forum - View Single Post - battlefield 3
Thread: battlefield 3
View Single Post
Old 09-29-2011, 03:01 PM   #48
Duhamel
Focus Enthusiast
 
Duhamel's Avatar
 
Join Date: Sep 2010
Fan#: 78883
Location: Edmonton, Canada
What I Drive: 2009 Silver SES

Posts: 281
Points 593, Level 11
Points: 593, Level: 11 Points: 593, Level: 11 Points: 593, Level: 11
Level Up 86% Completed
Level up: 86% Level up: 86% Level up: 86%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 Duhamel Good Standing Member
Buy-Sell-Trade Rating: (0)
I installed Origin and I was able to download and install the Beta. I had to change my settings in Origin though - I set Everyone for who can view my profile, and made sure Origin ID was checked. Then, when I tried to join a server, it told me to update my video driver (Nvidia) to version 285.27, so I did that. I then was able to join a server

I only had 5 minutes to play (not even), but I did get 2 kills. Gotta run, but once I get back I'm full on into it for the afternoon. Origin ID is PMD1977, for now.

Edit/Update - looked like there was only two maps available, but I was only able to connect to one of them. The servers were constantly full, 32 players, gonna try a 64 but I'm a little worried about ping. When I tried to filter the servers for North America, it wouldn't connect to any. So, I don't think there are any North American servers up yet/as of today, they all said the server name and then "Testing".

Didn't do overly well for my first match, 5 kills 10 deaths, meh. A few issues though, saw a couple of players "stuck" under the terrain - looked like a hack, but could be a glitch. No vehicles on the map I played, and the only game mode was Rush - I prefer Conquest.
__________________
SRI, Lowered (Pro Kit)

Last edited by Duhamel; 09-29-2011 at 09:25 PM.
Duhamel is offline  
    Reply With Quote