Focus Fanatics - View Single Post - PWSC with a P0133 HELP !!
View Single Post
Old 08-08-2011, 11:26 AM   #20
psycho401
Focus Jr. Enthusiast
 
Join Date: Oct 2007
Fan#: 50735
Location: Seattle, Wa
What I Drive: 2004, Red, Focus SVT

Posts: 37
FF Reputation: 1 psycho401 Good Standing Member
Buy-Sell-Trade Rating: (0)
P0133

I had the same issue with my powerworks. I bet you 10 bucks you throw in a oil catch can on you pcv you stop sucking oil through causing you O2 sensor to act up. Also a quick check pull you PCV line and I bet there is oil in there. If you dont wanna pay 70 bucks go to homedept and pick up an inline filter for 12 bucks in the air compressor section and go to auto zone and pick you up some 1/4 inch hose and connectors and cut you PCV line and install that inbetween.
http://focus.c-f-m.com/cfmoilseparat...svtengine.aspx

FYI dont listen to people that say as soon as a O2 sensor code is up buy a new sensor. There full of shit. 9 times out of 10 it isnt the sensor. You can replace the sensor a dozen times, turns the light out for a while but Like Tom said its a vac leak or somethink upstream causeing you sensor to trip out and the light will continue to come back if you dont fix the root problem. Thats why the sensor is there. But in your cause I bet its the need for the catch can. It solved my issues no p0133 and a happy filling catch can which i have to dump about every other fill up on gas. :) Enjoy the supercharger man
psycho401 is offline  
    Reply With Quote