Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 588whp 500tq just got off the dyno :)
View Single Post
Old 07-04-2011, 06:32 PM   #40
Roushturboedzx3
I Fab Too Much
 
Roushturboedzx3's Avatar
 
Join Date: Jan 2007
Fan#: 42814
Location: CLearwater, FL
What I Drive: 2002 Liquid Gray ZX3

Posts: 4,739
Points 14,483, Level 78
Points: 14,483, Level: 78 Points: 14,483, Level: 78 Points: 14,483, Level: 78
Level Up 9% Completed
Level up: 9% Level up: 9% Level up: 9%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 20 Roushturboedzx3 Great Standing Member
Buy-Sell-Trade Rating: (18)
So heres a little update. Thought i spun a bearing. had a loud knocking noise coming from the bottom end. Took the bottom end apart and nothing was wrong> thought wtf could it be. looked at the flywheel end of the crank and realized not all the bolts looked like they were the same depth. Took the tranny out and and inspected the flywheel two bolts were almost backed out and the rest were loose :/. Moral of the story im a Dumba$$ for re using the fly bolts 3 times with locktight lol. I bought some ARP bolts and everything is good so far. Lucky i caught it in time :)
__________________
New: 2012 Mustang GT premium
SOLD:RACE GAS 602whp 501tq Pump Gas SAE 454whp
Garrett GT3582r, Topmount, built motor, Ported head,Tuned by Fernando@RacingPartsSolution
I may not be the baddest, but the baddest dont Fu** with me
Roushturboedzx3 is offline  
    Reply With Quote