Focus Fanatics - View Single Post - A/C Questions before I take it in...
View Single Post
Old 07-04-2011, 07:03 AM   #10
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,126
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by Diesel View Post
And need to take freon pressure should be around 45lbs at low side.
NO: suction (Low) side pressure is dependent on ambient temperature if everything is working correctly. 45 psi might be the correct reading- but IMO I try to get it as low as possible because psi= evaporator temp. The worst that can happen is that your AC will not work at lower temperatures- like when it's 60 outside. Your LP switch is going to cut off the compressor when pressure gets low enough for the evaporator to collect ice which on 134 systems is around 25 psi. I generally look for 30-35 psi when temps are high so I have ice cold air, then if it doesn't work in the fall or spring- add freon sparingly until pressures are high enough for the system to run- and always double check your psi at higher than idle rpm. Another trick to ice cold air is to spray out your condenser periodically- like when you drain your coolant, take the extra hour to remove the radiator, and spray the condenser out from behind to remove bugs and road crud.

That's all beside the point ATM. USARice, your AC problems are most likely all in the dash. The whole AC system is connected so that if one part is not functioning- nothing works. For example, if the blower inside the cabin isn't working, the AC controls aren't going to allow the compressor to engage. That means that the engine cooling fans aren't going to kick on. If I were you, I'd fix the blower and vent selector first. Barring any other problems, that will likely fix your AC for you. The vent selector works on a cable, so follow the cable down and make sure there's not a physical obstruction behind the dash causing your vents from not switching. You can purchase a new cable from Ford if needed. I'll bet it's a physical obstruction though- like a coke bottle cap that got bounced up in a bad spot.

If you get around to getting the AC working, then when it dies due to a leak, we can help you fix it.

BTW, if you have gauges, without the engine or compressor on, the readings will be the same on low and high side. I would expect to see figures about 20-30 psi over ambient temp in F. Don't read too much into those figures unless you read lower than ambient temp- higher is ok for now.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote