Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - PWSC with a P0133 HELP !!
View Single Post
Old 06-11-2011, 08:33 AM   #3
Earls32
Focus Enthusiast
 
Earls32's Avatar
 
Join Date: Apr 2007
Fan#: 46470
Location: Fort Walton Beach, FL
What I Drive: 2003 Silver SVT Focus

Posts: 485
Points 3,319, Level 35
Points: 3,319, Level: 35 Points: 3,319, Level: 35 Points: 3,319, Level: 35
Level Up 80% Completed
Level up: 80% Level up: 80% Level up: 80%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 2 Earls32 Good Standing Member
Buy-Sell-Trade Rating: (12)
Yea it for the O2 sensor and it can make your car run like crap. what I do because I go through O2 sensors like crazy. (I know nobody likes Bosh sensors) but if you get it at advanced auto parts they come with a lifetime warranty, and every time mine goes out I just take it back to the store and get me a new one. O2 sensors are so EASY to mess up. it might be causing all your problems or you problems could be due to the fact of water being on your plugs. Replace your O2 sensor and change your plugs with a new set of SP463 and reset your battery and let us know from there. Maybe even do a compression test just to rule that out

Chris
__________________
SVT: Topmount GT3582R, SAE ? Whp ? Tq, Built motor, stock head, new #'s coming soon ;)
ZX3: RACE GAS 602whp 501tq Pump Gas SAE 454whp Garrett GT3582r, Topmount, built motor, Ported head, both Tuned by Fernando@RacingPartsSolution
Earls32 is offline  
    Reply With Quote