Focus Fanatics - View Single Post - 2010 Autocross vid Thread
View Single Post
Old 05-02-2010, 08:17 PM   #1
ZenRanger94
Focus Enthusiast
 
ZenRanger94's Avatar
 
Join Date: Apr 2007
Fan#: 46237
Location: Wilmington, DE, United States
What I Drive: 06 Silver ZX4 ST

Posts: 508
FF Reputation: 5 ZenRanger94 Good Standing Member
Buy-Sell-Trade Rating: (1)
2010 Autocross vid Thread

Starting fresh from the 2009 thread. Post up what ya got!

YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.


This was my best run, the most frustrating part, it was only my second of the day. It was a pretty aggravating day to begin with, lots of wind and it rained on and off all day. Speaking of which, if your club decides to race in the rain, call a stop to anybody who has slicks. we had a fully race prepped 80's camaro with too much hp and not enough grip in the wet (race slicks). he slid right into the building on the right in the second straightaway you see in the vid, you can probably see the hole in the siding he left, next to the white door. Luckily he didn't hit all that fast, and was okay. his car, and the siding on the building, not so much. So be careful out there, and if you see something that looks dumb, different, or dangerous, say something and get it fixed.


__________________
/\ /\ ST Crew #77 /\ /\
06 Focus ZX4 ST
F2 Intake, Trubendz 2.5in w/hfc, Eibach Pro springs, FRPP dampers, Motegi Tracklite wheels
ZenRanger94 is offline  
    Reply With Quote