Focus Fanatics - View Single Post - Ignition key stuck due to shifter? Help Please
View Single Post
Old 02-23-2009, 10:49 PM   #1
JoshCF
Focus Rookie
 
Join Date: Feb 2009
Fan#: 62995
Location: Denver
What I Drive: 2007 Silver 4d coupe

Posts: 2
FF Reputation: 1 JoshCF Good Standing Member
Buy-Sell-Trade Rating: (0)
Ignition key stuck due to shifter? Help Please

I have a 2007 Focus 4d coupe with 2.0 engine & Auto tranny. Today when I got to work I could turn off the engine with the ignition key, but not switch it to the "LOCK" position to remove the key. When I got home we started checking things out and have found out that if we remove the neg battery cable I can turn the key to the lock position and remove the key. I can insert, turn the key, go back to lock and remove the key OK as long as battery cable is off. As soon as it is connected then I can start the engine and drive the car OK, but I'm back to not being able to move the ignition switch to the LOCK position and remove the key again until I first remove the battery cable. I checked with a friend at FORD who says there is a sensor (or switch) in the shifter for the automatic transmission that will not let the ignition key move to the lock position until it senses the transmission has been shifted into "P" (park). I am putting the transmission in park before trying to turn off the engine and remove the key.

Of note, the transmission shift indicator (the little red line that moves when shifting gears) only moves to the "N" position when I put the shifter into park, but it has been this way since I bought the car last year and I never had this ignition switch problem before.

Has anyone else had this problem, and if so, how did you repair it? I'm new to this forum and tonight is my 1st time visiting. Any help will be very much appreciated. Thanks in advance!


JoshCF is offline  
    Reply With Quote