Ford Focus Forum, Ford Focus ST Forum - View Single Post - rough idle
Thread: rough idle
View Single Post
Old 10-15-2003, 02:14 AM   #2
Focus~Racer
Focus Enthusiast
 
Focus~Racer's Avatar
 
Join Date: Sep 2003
Fan#: 994
Location: CT. USA
What I Drive: Black 2001 4-Dr ZTS... Oh the heck with it... As long as it's a Focus!! :)

Posts: 109
FF Reputation: 1 Focus~Racer Good Standing Member
Buy-Sell-Trade Rating: (1)
Exclamation

I had the same problem with a 2001 ZTS that had just 20K.. Granted I only have a CAI but still, exactly what you described. So I asked around and found out that the OEM plugs and wires that Ford uses are really not that great!!

I used a set of BOSCH Wires and their +4 Platinum Plugs..
WHAT A CHANGE!!!

Installation is a snap, they give you the Dielectric Grease, and the plugs are all Pre-Gapped to save time. Just get some Permatex Anti-Seize compound, and your all set. Took me about 15 Minutes to do the wires and the plugs.

Also, once you do this grab some STP Fuel Injector Cleaner or Just a bottle of the STP Fuel System cleaner.. This way you cover all your bases. After I changed my plugs and wires I poured in the Fuel Injector Cleaner. My car exhaust smelled foul for the first few miles but after a "Good" run on the Highway, the idle was back to normal and everything was fine. I now have about 22K and I am still getting about 275-285 Miles to a Tank-full and the car is so smooth you would swear the engine is off.

I sure hope this will work for you, it's worth a shot.. ..Like I said it worked great for me ..
Focus~Racer is offline  
    Reply With Quote