Ford Focus Forum, Ford Focus ST Forum - View Single Post - 2nd AutoCross - 2nd place
View Single Post
Old 05-17-2004, 01:46 PM   #1
WD40
The Librarian
 
WD40's Avatar
 
Join Date: Mar 2004
Fan#: 5157
Location: Helena, MT
What I Drive: '04 Sonic Blue - SVT 3Door

Posts: 13,116
FF Reputation: 138 WD40 Excellent Standing Member WD40 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
2nd AutoCross - 2nd place

Ran yesterday, Sunday May 16th.
Raining like heck all day! (believe me, this is not normal for us)
I ended up 2nd OVERALL out of 30+ cars.
Best time of day was an Audi TT at 1:46.2.
Mine was a 1:46.3. I got beat by 1/10 of a second!!!
Good ole Suby Wagon, with a WRX engine had fast time, till the Audi and I put him to rest.

I left the TC on, and let it "do it's stuff".
Boy did it STICK.
Point it, hit the gas, and GO!
This was my first trip to our local track.
It's a testing area for the Highway Patrol, and the City Police.
Banked turns, elevation changes, just TOO cool!
It's about as close as I'll ever get to real road racing at this point in time.

It was SO much fun spanking the Vettes, Camaros, and Stangs.
Their power was no help at all yesterday.

I had a little "off" on my best run.
Dropped the RR off the pavement, but it popped me right back in line once it hit.
All I could think of was, "my wheels...oh no"!
Fortunately, I only had to dig a couple weeds out of the rim and I was good to go.
The wife was also along on that run.....
"Nice recovery, babe." "Well, thank you!"

Looks like I need another helmet now.
We may become a 2 driver team.

On a side note....
I don't know how Continental did it, but these tires are quite "grippy" in the rain.
I was very surprised, considering there's virtually no siping.



Last edited by WD40; 05-17-2004 at 02:15 PM.
WD40 is offline  
    Reply With Quote