Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Battery or alternator?
View Single Post
Old 05-17-2007, 01:19 PM   #1
focusmmuter
Focus Rookie
 
Join Date: Jan 2007
Fan#: 42492
Location: Antelope, CA
What I Drive: 2002 Mach Audio Edition

Posts: 24
FF Reputation: 1 focusmmuter Good Standing Member
Buy-Sell-Trade Rating: (1)
Battery or alternator?

Alright people frustration is kicking in. I have an 02 Mach Audio Edition ZTS. About 5-6 weeks ago, the battery light came on and off for a few days so i went to auto parts. They checked my charging system said battery was decent but charging system was a little low but not much. They told me to take out the alternator to have it checked and I never did. Battery light still came one but the last 2-3 weeks I havent seen the light come on at all. I noticed that after I turn off the car and leave the radio on for 10-15 mins, it will be slow to start when I come back hours later to turn it on. Yesterday, I was hanging out in the parking lot before work with car on and A/C on. I idled for about 20 mins. I turned off the car, got out, armed the alarm, when the horn sounded it sounded really weak. I got back in the car to start it and it barely turned over enough to start. I drove around the lot for a minute to "charge" the battery. I parked, turned it off, tried to turn it on and it was easier to start but still slow. So I went to work. 5 hours later I tried to start it and all it did was making a clicking noise. I left the key on the 'on' position for about a minute then turned the key to start and it started, slowly, but it started. Same situation happened weeks ago where if it clicks on start, I leave the key in the 'on' position for a while then i turn to start and it starts, again slowly but it starts. Could it be the battery since it doesnt like having accessories on after i turn off the car, or is it the alternator not giving enough charge???


focusmmuter is offline  
    Reply With Quote