Focus Fanatics - View Single Post - May 6 Auto-X Lordstown, OH
View Single Post
Old 05-16-2007, 04:24 PM   #28
FWDrift
Focus Rookie
 
FWDrift's Avatar
 
Join Date: May 2007
Fan#: 47113
Location: Cleveland, OH
What I Drive: 2000,silver,ZX3

Posts: 5
FF Reputation: 1 FWDrift Good Standing Member
Buy-Sell-Trade Rating: (0)
Yea thanks for the help Devon. I had 3 bad ground wires under the hood. Well two were totally broken the most important one from engine to frame which cracked off along with an aftermarket headlight ground wire. The last other bad looking ground was from some harness bundle which was really corroded and hanging by a thread.
After I went and watched my bro at Mid Ohio all weekend it inspired me to finally pound off my crappy old cross drilled rusty garbage rotors. lol well they have been on for 4 years. I put on OEM Brembo and PF Carbon Metalics which does the job really good and the price is perfect. Thats when I found the broken endlink btw. I want to get the car tuned up for a track days event so I pass tech with no issues.
I ran the car without the chip for the 1st time in years and wow does it LAG A$$ without it. I put that right back in and taped it in nice. Anyone know why the car feels like its holding back at WOT without the chip? Must be the timing fuel air thing in the ECU for economy. I like max WOT at my disposal since it's not much to begin with.
__________________
FC 65mm TB,Iceman W/AEM Dry filter,Shorty Header W/cat-pipe,FS Stealth CB,Optima Rear Batt/Box,Koni Sport Yellows,Ground Control CO Kit,Eibach A-R Kit,Quaife LSD, Fidanza LFW, Sachs PC,406 FD,Diablo Delta,Brembo,PFCM Pads, Goodridge BL
FWDrift is offline  
    Reply With Quote