Ford Focus Forum, Ford Focus ST Forum - View Single Post - DTC P0351 - Ignition Coil "A". At the end of my rope.
View Single Post
Old 03-27-2007, 01:34 AM   #5
Grumpy
Focus Addict
 
Join Date: Feb 2007
Fan#: 43791
Location: Vancouver, B.C.
What I Drive: 2005 Sonic Blue ZX3

Posts: 868
FF Reputation: 28 Grumpy Great Standing Member
Buy-Sell-Trade Rating: (0)
The heat-soaking is in reference to an electrical component sometimes failing after a certain period of operation, but working perfectly up to that moment. Transistors for example sometimes fail after getting "hot". I wasn't thinking of the coil because you had already changed it out. I'm just wondering if some (other) electronic component in the "trigger" circuit (which includes internal PCM circuitry) for this particular coil is failing. Because you have spark from the other coil, it at least is getting the ignition signal ("trigger") from the PCM, but I'm wondering if your "problem coil" for some reason stops getting it's PCM ignition signal after a period of engine operation. Is there an Ignition Signal code for this car or just the "coil" codes that you've stated? As I mentioned above because the other coil is firing I think the PCM is getting all the normal, required sensor info, but is there any troubleshooting reference to the Crankshaft Position Sensor? Is there a condensor in the coil power supply circuit? With the engine running have you "yanked and pulled" at all the associated electrical connectors and harnesses?
Grumpy is offline  
    Reply With Quote