Focus Fanatics - View Single Post - Rough Idle and SES Codes
View Single Post
Old 01-15-2007, 12:50 PM   #1
chkpnt
Focus Rookie
 
Join Date: Jan 2007
Fan#: 42901
Location: Bellingham, WA USA
Posts: 1
FF Reputation: 1 chkpnt Good Standing Member
Buy-Sell-Trade Rating: (0)
Rough Idle and SES Codes

I am trying to diagnose and fix a problem with my girlfriend’s automatic 2000 Focus SE. The car has an active service engine light and is throwing two codes. Related (or not) the car also has an extremely poor idle. It drives fine but when at idle it will “bounce” and nearly die. Could my trouble codes have anything to do with the rough idle? Where should I look for the problem? I have done some poking around and found what the trouble codes mean on this web site: http://www.obd-codes.com/trouble_codes/ford/. Here are what they mean and what I have done so far to remedy the issue(s).

Codes:

1405 – Differential Pressure Feedback Electronic Sensor circuit Upstream Hose

I checked the lines going from a solenoid (?) on the fire wall to the transaxle. Somebody had used fuel line which had disintegrated entirely from the inside and were almost entirely clogged. I replace this will proper silicon line but it still gives me the code. Are the lines I replaced the correct lines in regards to the error code (I can take pictures if that would help)? Could this have anything to do with the rough idle?


1409 – EGR Vacuum Regulator circuit malfunction

I am 99.9% sure this is due to an exhaust leak… There is ERG line going into the exhaust manifold and the gasket at that flag has blown out. I’m going to fix this and suspect the 1409 code will go away.


So far I have been unable to eliminate the rough idle. Any help would be very much appreciated. Thanks!


chkpnt is offline  
    Reply With Quote