Focus Fanatics - View Single Post - Went to the drag strip for the first time!
View Single Post
Old 06-19-2006, 07:06 PM   #19
chad_p71
Focus Enthusiast
 
Join Date: May 2005
Fan#: 22773
Location: Iowa
What I Drive: 2003 Pitch Black SVT

Posts: 124
FF Reputation: 1 chad_p71 Good Standing Member
Buy-Sell-Trade Rating: (1)
Do you just pop the clutch when you launch or do you slip the clutch?

Well my car has 23,000 on it. Im not sure what could possibly be out of tune causing me to be doggy in the first 660. I might check my spark plugs and see if I can learn whats going on in the cylinders, but the car is practically brand new all my fluids are clean, my Dual Stage Intake switch is in place (which can sometimes cause problems with svt owners). I have new tires, good alignment, air filter is a clean k&n unit, tranny/clutch shifts great, im not thinking the fuel filter would be bad at 23k....
I think if anything thats messing up my 660 its probably me! I may not be pushing the pedal all the way to the floor after my tires get done spinning.

I will take your guy's advice on lowering my tires to 25psi, I definityly think it may improve my launch as you say! I might dump my spare tire, jack and rear seats(if they come out easy) and run 1/4th of gas, but I doubt that will do too much of anything.
I will also "clean off" my tires with a short 5000rpm spin of the tires, I never did that when I ran. Again Im not sure if that will do much of anything besides wasting good rubber....

I am going back this friday! My goal is about 15.7 to 15.8, I think it is reachable in a stock SVT as the magazines say. Who ever thought just getting a few tenths would be such a pain! Anymore tips would be really helpful, I am still learning!!
__________________
17 inch O.Z. Racing Ultraleggera Rims

Last edited by chad_p71; 06-19-2006 at 07:12 PM.
chad_p71 is offline  
    Reply With Quote