Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Forced Induction (http://www.focusfanatics.com/forum/forumdisplay.php?f=44)
-   -   CFM Silicon Couplers for SVTF Intake Manifold (http://www.focusfanatics.com/forum/showthread.php?t=90505)

mike 1 07-04-2006 01:36 PM

CFM Silicon Couplers for SVTF Intake Manifold
 
Just thought I'd do a short-term testing (15 miles) write up on the CFM Silicon Couplers for the SVTF Intake manifold. If you dont know what I'm talking about; http://focus.c-f-m.com/index.asp?Pag...OD&ProdID=1108 click the link!

Ok, first, you will want to oder the couplers in either red, blue or black. I chose red beause thats just my accent color.

Tools you'll need to do it - 1/4 drive ratchet, 8mm socket, 1/4" socket, flat head screwdriver, pliers or wire cutters (dikes).

Prepare for the removal/ install:

Unclip the injector harness fromt he injecotrs and push it out of the way. Next, unclip the Fuel Pressure regulator/ sensor from the end of the rail and remove the vac. line from the sensor. Now, remove the two 8mm bolts securing the fuel rail, rock the rail back and forth til the injectors come loose, unplug the vac. line from the center/ bottom of the rail and swing the rail out of the way (I set the rail on my strut bar, worked perfect!). You are ready to begin!



Now its time to remove your rubber boots. If you have an 02 you definitely have those stupid 'clip' clamps. I know my friends 04 has the screw type clamps...those you just simply unscrew. To remove the clip clamps, just grab the head where it hooks and take pliers (I used cutters since it has a better head), grab the hook part (its at the 12 o'clock position) and just give it a twist. Then, just pull the whole clamp out. Repeat 7 more times. Now, once the clamps are off, grab the throttle body and push towards the firewall. This is just to separate the two halves. You dont have to make a lot of room, just enough to get the boots out. I grabbed a side and pulled it out from the sides. The way they are shaped makes it tough to pull straight up. Reapeat until all your boots are off.

Now to install the new couplers...what I did was took all my 8 clamps and pre tightened them. Its a lot easier this way since you wont have to hold while you screw the clamps a lot. Put two clamps on the MOTOR side of the intake manifold on each runner. Now, take a coupler and put it on the THROTTLE BODY side of the manifold (trust me!) Get the boot into position and then take one of the clamps and slide it into place and clamp it down snug. Do that on each runner. Now the tricky part (a second set of hands comes in here) grab the throttle body and alternator side of the manifold and lift and slip the assembly into the motor side of the manifold. 1 and 2 will go on easy, but 3 and 4 will fold under. Take a flat head it lift the folded part over the runner (your friend comes in here). Once you do that, pull the TB side into place as hard as possible and have your friend torque the MOTOR side clamps. Do 1 and 4 first. once you do that, do 2 and 3. Thats it. Go over and retorque the clamps with a socket/ ratchet. Reinstall your vac lines, fuel rail and injector harness and go for a drive!

Total time is about 15-20 minutes.

I would rate this on a difficulty scale of 2 out of 5. Its something anyone that can do basic car stuff can handle. The only 'scary' part, if you dont have a second person to help and you can get those couplers to unfold no matter what you try, you are stuck. Just be prepared to have a buddy available.

Now I can hold 10psi with out the boost leaking out of the rubber couplers.

For $20 + Shipping this is something we should ALL do! For turbos its a must, and for the NA guys, hey, it looks cool. When I get my camera back from my wife tonight, I'll take a few installed pictures!

bmylez 12-06-2009 01:55 AM

I know this is old, but it's a how-to, so it's always current [:)].
Just wanted to add my 2 cents.

If you remove your intake, it makes moving the intake manifold/throttle body a lot easier. Pre-tightening the clamps is a good idea like Mike said.

Lastly, this does *not* have to be a two-man job. I just got done doing this 5 min ago and it took a little while, but it's because I had stupid hang-ups. But the actual installing of the couplers and clamps was very straightforward. Don't be afraid to do it on your own, just line things up and all 4 couplers will go on in one shove [thumb]

1turbofocus 12-06-2009 10:47 AM

These are not a must to run boost , I did 20psi on the stock ones for years before I had to change them

Tom

bmylez 12-06-2009 11:23 AM

Yes but they look a lot better *and* two of my old ones were very mis-shaped and sagging, so it wasn't helping flow.

blackjack 12-08-2009 06:35 PM

Quote:

Originally Posted by 1turbofocus (Post 3049488)
These are not a must to run boost , I did 20psi on the stock ones for years before I had to change them

Tom


I agree with tom on this. Just make sure you clamps are tight, and you'll be fine

pitchedblack04 12-08-2009 08:22 PM

Quote:

Originally Posted by blackjack (Post 3053496)
I agree with tom on this. Just make sure you clamps are tight, and you'll be fine

Everyone knows they are not a must... but just like bmylez i had two couplers that had dropped and was not flowing very efficiently.

SvviftSVT 02-23-2012 02:19 PM

i will be doing this today. i know "holy thread revival batman" but used the search feature and this seems easy enough, but its still nice to read other people's tips.


All times are GMT -5. The time now is 03:42 PM.