Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   Drag Racing (http://www.focusfanatics.com/forum/forumdisplay.php?f=96)
-   -   My car broke at the track (VIDEO!) (http://www.focusfanatics.com/forum/showthread.php?t=75584)

2.0TooSlow 02-21-2006 12:17 AM

My car broke at the track (VIDEO!)
 
Here's a video showing the damage. It speaks for itself.

Right Click Save As

Crimson 02-21-2006 12:24 AM

Ouch. What the heck happened?

BillyD 02-21-2006 12:25 AM

haha...that sucks

1sloho 02-21-2006 12:33 AM

DUDE!!! the same exact thing happend to me a few days ago. although mine was more severe. popped the hood and my engine was leanin to the left. bracket that was holdin the mount completly broke.

Hillyard 02-21-2006 12:41 AM

What revs were you guys pushing?

2.0TooSlow 02-21-2006 09:40 AM

I launched at around 3500 but wheelhopped like a bitch.

Hillyard 02-21-2006 10:39 AM

Quote:

Originally posted by 2.0TooSlow
I launched at around 3500 but wheelhopped like a bitch.
ya...that will do it...

sidenote: Is that you in the movie talking? You are talking all fast and using your hand directions...looks like me if I broke something on my car... I had a good laugh and no it wasn't from the broken SVT because that had to suck...

focusedaddiction 02-21-2006 06:23 PM

damn that looked painfull[ohcrap] 1/4 mile I take it? wow!

fresnofocus 02-21-2006 07:21 PM

was it the motor mount that broke??? because my motor mount bolts broke 2 times already. it messed up my timing belt because it was rubbing on the motor mount, the mount shifted into the belt. the 2nd time it happened i caught it b4 it got worse, i jusdt had to put a new bolt in.


All times are GMT -5. The time now is 12:33 AM.


http://www.focusfanatics.com/aboutus/copyright.asp