Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   ZETEC Performance (2000-2004) (http://www.focusfanatics.com/forum/forumdisplay.php?f=39)
-   -   Performance Engine Roll Back To Factory Setting's (http://www.focusfanatics.com/forum/showthread.php?t=64132)

ROC 10-28-2005 07:55 PM

Performance Engine Roll Back To Factory Setting's
 
Can any one please help me out on this issue. i had took my focus over to mcnews for some minor engine mod's 65mm throttle body, esslinges cam gear's, ford racing cam gear's, and a sct program chip, tru bend flex pipe, after one full month my focus went back to factory settings, originally i had a superchip installed on it- borla full catback-random tech cat-aem exhaust-jba short headers. everything seen fine for the first 2 1/2 or 3 years without any problems.

until a month ago i requested for the help of the guy's from mcnewsautomotive.com in dillsburg,pa there i left my 2000 zetec sedan focus for some mod's. first i want to say that im not kicking dirt on mcnews with all respect. i did mention to them at mcnews in an e-mail that i had no other choice but to ask for help from the members of www.focusfantics.com

at mcnews i was told that yes they can make my focus more faster with 129 horsepower, i believe that it was going to be an additional 129 more horsepower to that of the horsepower that came with my focus, but indeed i later found out from ray at mcnews that it would only had a total torque of 129 at the wheels. any way what i don't seem to understand is why my focus reads a code P1600 and P0705 which mcnews told me it was a tranny sensor that does not read the shifter, But what about the power it's all gone back to stock ? i just don't get it ? why did it go back to stock mode. now my ford focus drives just the way it did when i first bought it back in 1999.

i don't even here the car reaving you know it does'nt sounds no more like a mustang, it lost all the torque power, with the mods my car has this should not be happening ? i spent $2,800 and some change at mcnewsautomotive for this. well they did replace my front calipers which they said took 4 hours to replace at $75.00 an hour which i know is more than what the ford dealership would had charge me. i even ask the guy's at mcnews in several e-mails about the suspension system for my focus, i remember when they first told me roush would be best, then on another date they told me SVT supension would be great, they even try to sell me airbag's as for suspension, even wheels when a have konig wheels. they took two weeks to finish my zetec focus when it should of taken them 4 to 5 day's they made me wait for 16 day's to get my car back when i hade to take a taxi cab from home to work and work to home for 16 days.

htey told me it took them an hour to put in the 65mm throttle body at $75.00 when we all know it takes about 20 minutes to do the job. the thing is that i was very upset at the waiting time to get my car back, and the springs they put in my car ankai what ever the name are they really are sort of stiff and they new i told them i wanted a smooth , smooth ride. money was'nt my issue ? i just trusted them which my zetec ford focus and i was paying to get the best quality work that i believe i did not recieved. now a month later all the mods and torque has disappear where is the power - the torque and the horses at ? the damn car when back to stock mode just as if i just drove it out of the dealership.

please, please any one help me out. what should i do. i just wont ever trust the people at mcnewsautomotive with my focus ever again. im not trying ti kick dirt on them im only speaking about my bad experience of what happen to my focus after they did the work. i don't want anyone to have to go through what has happen to me. look i have all my original receipts of all the parts they installed on my focus and what was done to it ? including the sheet where supposedly they said it has 129 torque. i will mail copy's of all my receipts to everyone if no one believe's me. do i have to go to the dealership to get a tranny sensor so that my focus gains back the powerhorse and stenght ? Julio Hernandez Newark,New Jersey work phone 973-623-8282 cell phone 973-704-3069- home phone 973-484-5453

ROC 10-28-2005 08:10 PM

Engine went back to stock after mods
 
please help roc .... look at my post , by: ROC

Knuckles899 10-28-2005 09:09 PM

Sux having an automatic transmission doesnt it? Look at the list of my mods i have on my manual, i bought almost all of them from Ray at Mcnews auto. I might have 150hp and torq. without the nitrous and ive also spent a lot of money so far into the game.
You should do some research before you think your going to get 129 more hp than you have which is like 125 for a total of 254hp for $2800 without some type of boost especially with an autotragic transmision that can only handle 140ish hp in the first place. To have that type of hp your going to need to upgrade your auto with something like a lentec or equivlent and then go into turbo, supercharger, or nitrous oxide. I understand what your saying but hp cost a lot of money especially when you have very high hp goals on a economy car.
Have you contacted them yet with your questions, ive found them to be very helpfull to me im pretty sure they'd do the same for you.

Knuckles899 10-28-2005 09:18 PM

Also i work in the motorsports area myself and the service techs have to charge an ideal time frame for performance add ons. Sure a lot of us know it may only take 20 to 30 mins to do a throttle body change...........but you gotta remember these techs make a living doing this stuff and its not like your paying your buddy to do it. Its just gotta be justified time for money uno and knowing that it should be getting done right and not by your neibor. I do understand your fustration but when it comes down to it i do all of my mods myself if i know its not to hard to do and even if it is, this whole modding thing should be something you learn from and grow with i know i have. Also id see if you can take your car there and have them check your computer chip to see if anything has changed for sure, or at least send the chip to them to check out.

kenpokid 10-28-2005 10:15 PM

I don't get what your saying? McNews just doesn't screw people over. And I doubt they would take that long to install the TB...I don't think you should be bringing this to a forum anyway. Why don't you work it out with the people at McNew's.

Yel900rr 10-29-2005 12:06 AM

I don't have a problem with this. This car needed alot I mean ALOT more work than what performance mods were installed. Ordering factory parts in to replace the multiple broken pieces on this car took time and added up. Roc you should be mad at the peolple that butchered your car before we worked on it. Broken bleeders on the brakes so we couldn't bleed the brakes that had a ton of air in the lines, clips not in rear brake line and lines were rubbing metal to metal, front stainless brake lines rubbing the tires, trans pan leaking, stripped lugs, had coilovers on and we needed to get spring seats for the front struts. We installed Apex 1.5 drop springs the car had 225 45 17tires with the wrong offset wheels so the rear tires rub.

If we knew what we were getting into when you made the appointment things would have went faster and we are swamped in the shop and on the dyno. So we can't push other appointments back to take care of another car that we weren't totally prepared for.

You car ran great when it left and made the power we figured it would.

lgzx5 10-29-2005 12:22 AM

What you guys are forgetting is that there is a book they look at to get install times if it's 20 mins it get's rounded to an hour... from there they can charge a maximum of 85 an hour

kenpokid 10-29-2005 06:21 AM

Quote:

Originally posted by lgzx5
What you guys are forgetting is that there is a book they look at to get install times if it's 20 mins it get's rounded to an hour... from there they can charge a maximum of 85 an hour
good point[thumb]

jerryzx3 10-29-2005 08:19 AM

It sounds like you got used to the mods and now it feels stock again. Maybe you should go test drive a new one and then get back in yours and feel it. Even if the computer did somehow "go back to stock" with your cams and other mods it will not run stock. Also it does take a while to order parts from Ford, it took 6 weeks to get my clutch and differential done.

2Slik 10-29-2005 11:11 PM

Wow what a ridiculous post. McNews has better prices on their products over any other supplier you can find 90% of the time. Now this is more of a service problem but still.

I know this is mean but you really sound like an idiot. Calling out one of the best suppliers that we focus owners have and complaining the way you are is not winning anyone over. Type correctly and stop being so offensive. This sounds like the stupid ricer mentality, maybe you should watch the ricer song..... http://videos.streetfire.net/Player....2F9AE359C1&p=0

On the suspension issue what type of suspension is all up to your personal choice. If one susupension was better than the others in every way why would there be other products out there? On the subject of service. You have to take in consideration even the easiest things can end up taking forever. If your car was in bad shape as Mcnews says then there you have it. I've worked on my car thinking i'd get a particular task done in an hour and its taken a whole day. Thats just the way it is.


All times are GMT -5. The time now is 10:07 AM.