Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Forced Induction (http://www.focusfanatics.com/forum/forumdisplay.php?f=44)
-   -   Supercharger with problems (http://www.focusfanatics.com/forum/showthread.php?t=320559)

teh_touch 07-07-2013 05:26 AM

Supercharger with problems
 
I have an '02 Focus SVT I bought with a supercharger on it. Now, I was wondering how to tell if it has been mapped through the computer or if no can just take it off. When I start off I can only go to 3k rpms in 1st thru 3rd before it sputters. Any help on how to fix/remove supercharger?

Sent from my SCH-I535 using Xparent Cyan FF Mobile

teh_touch 07-07-2013 08:27 PM

I can't get more than 3lbs of boost in 1st thru 3rd. It's a 6sp manual

Sent from my SCH-I535 using Xparent Cyan FF Mobile

zetecDon 07-07-2013 10:22 PM

Moved to "General Forced Induction".

kwg2371 07-08-2013 12:41 AM

have you checked for vac leaks?

teh_touch 07-08-2013 01:09 AM

I'll check tonight and post back asap

Sent from my SCH-I535 using Xparent Cyan FF Mobile

teh_touch 07-08-2013 03:53 AM

No vacuum leaks. Cleaned the MAF but to no avail.

Sent from my SCH-I535 using Xparent Cyan FF Mobile

ZXthrizzle05 07-08-2013 07:33 AM

How did u check for vac leaks? Also it could be tune related issue with fueling

teh_touch 07-08-2013 08:32 AM

One can of carb cleaner with the engine running.

Sent from my SCH-I535 using Xparent Cyan FF Mobile

Floodyou76 07-08-2013 11:05 AM

a little info might help....S/C type? you have tuner? if so, type? wideband? if so, whats the A/F read like at 3k? where is the intake? have you tried cleaning the MAF? what happened before it started doing that? how long have you had it running ok prior to acting up? how does it idle?

if u you cant get past 3k, then that's why you only see low boost RPMs=boost, so I would think its not S/C related, at least at first.

teh_touch 07-08-2013 12:21 PM

I can go higher than 3k but it starts sputtering higher than 3. It's ran this way since I bought it. It seems to idle fine. Its an injen short ram intake. I don't know how to find if it has a tuner let alone what wideband is. I'll have to look at the S/C when I get a chance to see what brand. I cleaned the MAF last night and made no difference.

Sent from my SCH-I535 using Xparent Cyan FF Mobile


All times are GMT -5. The time now is 10:48 PM.


http://www.focusfanatics.com/aboutus/copyright.asp