Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   Car Audio, SYNC, MyFord Touch & Electronics (http://www.focusfanatics.com/forum/forumdisplay.php?f=51)
-   -   Screen/Display Dead (http://www.focusfanatics.com/forum/showthread.php?t=319968)

Flyersrock87 06-27-2013 06:22 PM

Screen/Display Dead
 
So I drove about 200 miles from DC to Philly with no problems. When I started the car to leave, the display never came on, and hasn't been on since (this started Sunday, it's now Thursday). I tried disconnecting the battery for a couple minutes, but to no avail.

Any ideas?

EDIT: 2013 Titanium, MFT, no Nav.

dervari 06-27-2013 07:27 PM

Warranty claim?

FordIVTteam 06-28-2013 09:56 AM

Quote:

Originally Posted by Flyersrock87 (Post 4791404)
So I drove about 200 miles from DC to Philly with no problems. When I started the car to leave, the display never came on, and hasn't been on since (this started Sunday, it's now Thursday). I tried disconnecting the battery for a couple minutes, but to no avail.

Any ideas?

EDIT: 2013 Titanium, MFT, no Nav.

Hi, Flyersrock87 -

You'll need to make an appointment with your dealership to have them diagnose and fix this issue. Let me know how it goes.

Rebecca

slybarman 06-28-2013 10:19 AM

Mine had appeared dead once before only to come back to life after a reboot. You might want to try the delayed reboot before going to the dealer.


. . . or puling the MFT fuse . . . or disconnecting the batter and reconnecting.

TKM3RD 08-07-2013 04:19 PM

Screen Dead
 
When I had the same issue, I tried everything I could think of. Then I realized I had a CD in the player. I ejected it, shut down the car, and restarted it without the CD. Worked like a champ.


All times are GMT -5. The time now is 11:37 AM.