Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   DURATEC Ti-VCT Performance (2012-Current) (http://www.focusfanatics.com/forum/forumdisplay.php?f=101)
-   -   Rear motor mount installation (http://www.focusfanatics.com/forum/showthread.php?t=314952)

Juicedz 04-23-2013 07:09 PM

Rear motor mount installation
 
I just received my Central Florida Motorsports lower engine mount for 2012+ Focus/st I've heard it's just a focus electric mount but I digress. Is the removal process the same on our motors as depicted in this video for a st?

YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.

StingRay 04-23-2013 07:30 PM

Yes for the most part. The base foci are actually easier since there is no downpipe support bracket.

Juicedz 04-23-2013 08:13 PM

Red lock loctite on the factory bolt? I look forward to feeling the difference.

StingRay 04-23-2013 08:25 PM

Yeah, red loctite lol. Its fun to take out

Juicedz 04-23-2013 09:02 PM

Quote:

Originally Posted by StingRay (Post 4696892)
Yeah, red loctite lol. Its fun to take out

Better safe than sorry. Thanks dude

RedVAhb757 04-24-2013 11:40 AM

Quote:

Originally Posted by Juicedz (Post 4697023)
Better safe than sorry. Thanks dude

On both bolts?

Juicedz 04-24-2013 02:49 PM

Quote:

Originally Posted by RedVAhb757 (Post 4697784)
On both bolts?

I'm sorry, I don't understand your question? Are you asking if red loctite should be used on both bolts.

RedVAhb757 04-24-2013 04:13 PM

Quote:

Originally Posted by Juicedz (Post 4698165)
I'm sorry, I don't understand your question? Are you asking if red loctite should be used on both bolts.

Yes I am. Do you need red loctite on both bolts, and if not then which bolt

StingRay 04-24-2013 04:42 PM

I used red on the one into the frame, and blue on the one in the trans bracket. Red probably isn't necessary on the one, but it had it on the factory bolt so I applied a very small amount going back in.

Juicedz 04-24-2013 05:53 PM

Quote:

Originally Posted by RedVAhb757 (Post 4698297)
Yes I am. Do you need red loctite on both bolts, and if not then which bolt

The mount itself utilizes a single through bolt design. I will place red loctite on the threads of that bolt. The others will probably just get retorqued. What's the tq rating on the bolts by the way? Last autozone/advanced auto trips I made they didn't have Haynes manuals on these cars yet.


All times are GMT -5. The time now is 05:20 PM.