Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   Drag Racing (http://www.focusfanatics.com/forum/forumdisplay.php?f=96)
-   -   Stating (http://www.focusfanatics.com/forum/showthread.php?t=313569)

FocusHero 04-06-2013 01:32 PM

Stating
 
I have a 2003 svt with a few bolt ons i went to the track for the first time yesterday and ran terrible time (17.2 and 17.3) i was nevous but what is the best way to launch

streetfocus 04-06-2013 06:08 PM

How was your launch? If you got a lot of wheel hop and/or had traction problems you should back off the initial starting RPMs. I have not run an svt, so maybe an experienced svt member can chime in, but my generic advice would be to hold the clutch in and hold the rpms at about 2000-2500. Let the clutch pedal up when you see the third yellow light on the tree (our cars are not really fast enough to wait until you see green; by then you will have a slow reaction time). If you want to power shift from there on I would at about 5800. You can adjust your launch up/down in starting rpms according to how your traction is.

Svt_kid 04-07-2013 01:21 AM

I launched my svt at 2k today and made an 11.40 on the 1/8th. Sadly that was the only pass i made hehe..

streetfocus 04-09-2013 10:01 AM

Hmm. I do a 10.2 in the 8th, so you should be at least there with practice.

Svt_kid 04-09-2013 09:07 PM

Quote:

Originally Posted by streetfocus (Post 4676390)
Hmm. I do a 10.2 in the 8th, so you should be at least there with practice.

I broke my axles on the second launch. I went up to 3krpm and dropped the anchor and snapped the passnger side axle at the cv joint and broke the clamps on the driver side replaced one to get the car driveable just waiting for the next axle now, i put them in early december. I dont think my car can handle digs... so i dont think ill be trying that anytime soon. but yea my time could have greatly been improved i was slow off the line. First time i ever did a dig.

StingRay 04-09-2013 09:11 PM

Quote:

Originally Posted by Svt_kid (Post 4677608)
I broke my axles on the second launch. I went up to 3krpm and dropped the anchor and snapped the passnger side axle at the cv joint and broke the clamps on the driver side replaced one to get the car driveable just waiting for the next axle now, i put them in early december. I dont think my car can handle digs... so i dont think ill be trying that anytime soon. but yea my time could have greatly been improved i was slow off the line. First time i ever did a dig.

You must have hooked like a m-fer haha. I'm always scared of breaking an axle.

Svt_kid 04-09-2013 09:25 PM

Clutch masters stage 2, it didnt let go at all lol

streetfocus 04-09-2013 10:54 PM

Holy crap

iminhell 04-11-2013 10:37 PM

Flat foot and slip the clutch, don't dump it. You want grip, not tire spin/wheel hop.


I use a different method in my tune, tq limiting. I've got it set so I can go WOT right off the line and not spin one bit, though power is reduced.
I have to get my 2 step setup better this year.

I did consistent 2.3 60' (5 runs within .03 of eachother). Best of 14.9 in the 1/4.

streetfocus 04-12-2013 09:14 AM

I have never heard of this method. There is not much torque, but you are starting in the power band? Explain this for us. Manual?


All times are GMT -5. The time now is 10:28 AM.